4WebHelp
 FAQ  •  Search  •  User Groups  •  Forum Admins  •  Smilies List  •  Statistics  •  Rules   •  Login   •  Register
Toggle Navigation Menu

 Problems with PHP and Apache 2.2 on Windows XP
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic
Author Message
bachya
Junior WebHelper
Junior WebHelper


Joined: 23 Jun 2006
Posts: 1

PostPosted: Sat Jun 24, 2006 3:24 am (10 years, 3 months ago) Reply with QuoteBack to Top

Hi all,

I'm trying to install Apache (along with PHP and mySQL) to my computer, as a means of testing. I've been following Amadeus Stevenson's tutorial, and everything has worked fine so far...except for the installation of PHP.

When I try to open a PHP file through 127.0.0.1, I get this message: "You don't have permission to access /php/php.exe/phpinfo.php on this server."

Upon looking at the Apache error logs, I find this: "[error] [client 127.0.0.1] client denied by server configuration: C:/php/php.exe"

I know this is probably not as general a question as I'm hoping it is, but can anyone steer me in the right direction? I was having "forbidden" errors when configuring CGI, as well, but that was fixed through some faulty directory names in the Apache configuration file...but that doesn't appear to be the case, here.

I really appreciate any advice or tips you might have.
OfflineView User's ProfileFind all posts by bachyaSend Personal Message
Anghel132
Junior WebHelper
Junior WebHelper


Joined: 29 Jun 2006
Posts: 1

PostPosted: Thu Jun 29, 2006 11:35 am (10 years, 3 months ago) Reply with QuoteBack to Top

Confused

Im sorry to add to this, but I get the same problem.
OfflineView User's ProfileFind all posts by Anghel132Send Personal Message
stipko
Junior WebHelper
Junior WebHelper


Joined: 08 Jul 2006
Posts: 1

PostPosted: Sat Jul 08, 2006 6:11 pm (10 years, 2 months ago) Reply with QuoteBack to Top

try to correct httpd.conf file.
At about line 159 there is by default this:

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Satisfy all
</Directory>

insert this:

<Directory />
Options Indexes FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.1
Satisfy all
</Directory>
OfflineView User's ProfileFind all posts by stipkoSend Personal Message
wscreate
Junior WebHelper
Junior WebHelper


Joined: 24 Jul 2006
Posts: 6

PostPosted: Mon Jul 24, 2006 5:26 pm (10 years, 2 months ago) Reply with QuoteBack to Top

I wasn't the orignal poster, I found this thread via Google. However, I have had the same problem with Apache 2.2 and PHP 4.4.2. Anyway, you're suggestion fixed it. Thanks Stipko

# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.1 <<<< ADD THIS
Satisfy all
</Directory>
OfflineView User's ProfileFind all posts by wscreateSend Personal Message
Display posts from previous:      
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic


 Jump to:   




You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot edit your posts in this forum.
You cannot delete your posts in this forum.
You cannot vote in polls in this forum.


Page generation time: 0.09311 seconds :: 17 queries executed :: All Times are GMT
Powered by phpBB 2.0 © 2001, 2002 phpBB Group :: Based on an FI Theme