4WebHelp
 FAQ  •  Search  •  User Groups  •  Forum Admins  •  Smilies List  •  Statistics  •  Rules   •  Login   •  Register
Toggle Navigation Menu

 htaccess help
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic
Author Message
dmc1906
Junior WebHelper
Junior WebHelper


Joined: 16 Mar 2005
Posts: 2
Location: Ohio

PostPosted: Wed Mar 16, 2005 6:52 am (12 years, 8 months ago) Reply with QuoteBack to Top

I really have searched the posts and googled for a long time before asking this. I just cannot get htaccess and htpasswd to work. I really need help.

Here is what is in my .htaccess file:

AuthName "Private Area"
AuthType Basic
AuthUserFile /clients/.htpasswd
<Limit GET>
require valid-user
</Limit>

The above is not my real AuthUserFile. I removed it because of the public nature of this forum. However, I've spelled this path using "phpinfo()" and what I found under "Document Root". I placed .htpasswd in the same directory. I realize this is not as secure, but right now, I am just trying to verify that I can make it work. I created .htpasswd with a text editor with the following contents:

username:encryptedpassword

Where username is a real username, and encrypted password is a password I encrypted using one of the many thousands of encryption sites available.

The site is on GoDaddy (if that helps), and I understand there should be no SALT arguments required. I've placed these two files inside a directory called "clients/" which as you can see from above, I spell out. One of two things happens when I play with the code.

1) Nothing

or

2) I am prompted for the pwd and username, over and over again.

Please help. If you are going to send me to a tutorial, thanks anyway. I've read at least a dozen of them, and I'm not sure you are aware of one I havent read. Is there a simple step I've forgotten because I'm so tired? Thanks for any advice any of you might have.
OfflineView User's ProfileFind all posts by dmc1906Send Personal MessageSend emailVisit Poster's Website
dmc1906
Junior WebHelper
Junior WebHelper


Joined: 16 Mar 2005
Posts: 2
Location: Ohio

PostPosted: Wed Mar 16, 2005 7:50 am (12 years, 8 months ago) Reply with QuoteBack to Top

6 hours I been working on this thing. Ugh.

I hate it when forum posters figure out what was wrong and write something like "oops I figured it out, thanks guys. good night". Maybe the rest of us would like to know what you did. So I will take a moment to explain my own ignorance.

Based on the number of help requests concerning htaccess, it is clear that this is not as simple and straightforward as some think. In my case, I was sure I had done everything right, and I pretty much had. Then, on a whim, I checked the method of upload I was using to get my htaccess and htpasswd files to my GoDaddy server. Sure enough, I was not uploading them as ascii files, which is required (I think).

I have recently started using a new FTP program. Actually, it is PHP Designer, which I absolutely love (and its free). But I have not figured out how to manage the upload method yet. So when I went back to CORE FTP (which is also a fine ftp client), I uploaded the same files, and bang - it works.

Sorry to those of you who are bored with this level of detail. I hope this helps somebody somewhere. Don't give up. There is a solution.
OfflineView User's ProfileFind all posts by dmc1906Send Personal MessageSend emailVisit Poster's Website
Display posts from previous:      
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic


 Jump to:   




You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot edit your posts in this forum.
You cannot delete your posts in this forum.
You cannot vote in polls in this forum.


Page generation time: 0.061111 seconds :: 17 queries executed :: All Times are GMT
Powered by phpBB 2.0 © 2001, 2002 phpBB Group :: Based on an FI Theme