4WebHelp
 FAQ  •  Search  •  User Groups  •  Forum Admins  •  Smilies List  •  Statistics  •  Rules   •  Login   •  Register
Toggle Navigation Menu

 Added htaccess to file "Nothing Happens"
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic
Author Message
su_jump
Junior WebHelper
Junior WebHelper


Joined: 18 Nov 2004
Posts: 5
Location: Austin, Tx

PostPosted: Tue Jan 11, 2005 8:04 pm (12 years, 10 months ago) Reply with QuoteBack to Top

Hello all,
Ive used htaccess successfully before with no problems. Now I changed web host (using FreeBSD) which should work with htaccess. Created new directory to be protected and added the htaccess file to the root of that directory. Also added the htpasswd file outside of the root directory to be protected. Okay, youd think everything would work great. Well, when I go to the protected page..nothing happens, it just goes directly to the page Im trying to protect with no login box or anything. What gives?

Thanks for the help. Very Happy

Quote:
AuthUserFile /home/aapff/public_html/_private/.htpasswd
AuthGroupFile /dev/null
AuthName "Members Only Area"
AuthType Basic
authPAM_enabled off


ErrorDocument 401 /Sorry.html
<Limit GET POST>
require valid-user
satisfy all
</Limit>
OfflineView User's ProfileFind all posts by su_jumpSend Personal Message
Daniel
Team Member



Joined: 06 Jan 2002
Posts: 2564

PostPosted: Tue Jan 11, 2005 9:04 pm (12 years, 10 months ago) Reply with QuoteBack to Top

Does your new web host use Apache?

________________________________
Image
OfflineView User's ProfileFind all posts by DanielSend Personal Message
su_jump
Junior WebHelper
Junior WebHelper


Joined: 18 Nov 2004
Posts: 5
Location: Austin, Tx

PostPosted: Tue Jan 11, 2005 10:17 pm (12 years, 10 months ago) Reply with QuoteBack to Top

This is what I found.


Operating system:
FreeBSD 4.10-SATA-RELEASE

AnyDBM_File
Apache
Apache::AuthDBI
Apache::Connection
Apache::Constants
Apache::Constants::Exports
Apache::DBI
Apache::Debug
Apache::ExtUtils
Apache::FakeRequest
Apache::File
Apache::httpd_conf
Apache::Include
Apache::Leak
Apache::Log
Apache::ModuleConfig
Apache::MyConfig
Apache::Opcode
Apache::Options
Apache::PerlRun
Apache::PerlRunXS
Apache::PerlSections
Apache::RedirectLogFix
Apache::Registry
Apache::RegistryBB
Apache::RegistryLoader
Apache::RegistryNG
Apache::Resource
Apache::RPC::Server
Apache::RPC::Status
Apache::Server
Apache::SIG
Apache::SizeLimit
Apache::SOAP
Apache::src
Apache::StatINC
Apache::Status
Apache::Symbol
Apache::Symdump
Apache::Table
Apache::test
Apache::URI
Apache::Util
Apache::XMLRPC::Lite
OfflineView User's ProfileFind all posts by su_jumpSend Personal Message
Daniel
Team Member



Joined: 06 Jan 2002
Posts: 2564

PostPosted: Wed Jan 12, 2005 6:18 am (12 years, 10 months ago) Reply with QuoteBack to Top

Have you asked your host if they've disabled the use of .htaccess files?

________________________________
Image
OfflineView User's ProfileFind all posts by DanielSend Personal Message
su_jump
Junior WebHelper
Junior WebHelper


Joined: 18 Nov 2004
Posts: 5
Location: Austin, Tx

PostPosted: Wed Jan 12, 2005 6:50 am (12 years, 10 months ago) Reply with QuoteBack to Top

I checked before I started all this. But its always good to recheck. I called them to confirm and yes .htaccess files can be used on the server.
OfflineView User's ProfileFind all posts by su_jumpSend Personal Message
Display posts from previous:      
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic


 Jump to:   




You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot edit your posts in this forum.
You cannot delete your posts in this forum.
You cannot vote in polls in this forum.


Page generation time: 0.052693 seconds :: 17 queries executed :: All Times are GMT
Powered by phpBB 2.0 © 2001, 2002 phpBB Group :: Based on an FI Theme