4WebHelp
 FAQ  •  Search  •  User Groups  •  Forum Admins  •  Smilies List  •  Statistics  •  Rules   •  Login   •  Register
Toggle Navigation Menu

 <input type="image"...> problem with IE
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic
Author Message
adam
Forum Moderator & Developer



Joined: 26 Jul 2002
Posts: 704
Location: UK

PostPosted: Sat Nov 16, 2002 8:55 pm (13 years, 8 months ago) Reply with QuoteBack to Top

I have one hell of an annoying problem...I'm using images as form submit buttons. I need to do different stuff based on which button was used to submit the form. Here is the code I use:

<input type="image" name="submit" value="submit" src="/images/next.png" alt="Next">&nbsp;<a href="/members/" title="Cancel">

When I use mozilla, I can use the variable $submit in my script to determine which image was clicked on. IE doesn't send this information, so the variable is NULL. This is not good for my script.

My first reaction is to go to the roof of my house and yell "microsoft suck" as loud as I can (preferably with some kind of megaphone), but I realise this would not be productive. so, instead, I decided to ask you lovely people for a magical solution...don't disappoint me! Very Happy

MICROSOFT SUCK!!!!!!

Just had to do it...

________________________________
It's turtles all the way down...
OfflineView User's ProfileFind all posts by adamSend Personal MessageVisit Poster's Website
Display posts from previous:      
Post New TopicReply to Topic
View Previous Topic Print this topic View Next Topic


 Jump to:   




You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot edit your posts in this forum.
You cannot delete your posts in this forum.
You cannot vote in polls in this forum.


Page generation time: 0.026032 seconds :: 17 queries executed :: All Times are GMT
Powered by phpBB 2.0 © 2001, 2002 phpBB Group :: Based on an FI Theme